Configuración básica de red 3 (Rutas dinámicas,RIP)

Bueno vamos a comenzar los ejemplos de configuración de rutas dinámicas con el protocolo de enrutamiento RIP,(Routing Information Server). Como ya sabemos pertenece a la familia de protocolos IGP, (Interior Gateway Protocol) y presenta las siguientes características:

  1. Pertenece a la familia de protocolos de vector distancia los cuales buscan el camino más corto determinando la dirección y la distancia a cualquier enlace. Estos algoritmos de enrutamiento basados en vectores, pasan copias periódicas de una tabla de enrutamiento de un router a otro y acumulan vectores distancia.

  2. La métrica empleada es el número de saltos que hay entre el router origen y destino. Una red directamente conectada tendrá un coste igual a 1.

  3. Para el intercambio de información emplean datagramas UDP.

  4. El Puerto reservado para este protocolo es el 520.

  5. Emplea el algoritmo de Bellman-Ford distribuido. Para más información podéis visitar esta página: http://www.it.uc3m.es/~prometeo/rsc/apuntes/encamina/encamina.html

  6. Las rutas tienen un tiempo de vida de 180 segundos. Si pasado este tiempo, no se han recibido mensajes que confirmen que esa ruta está activa, se borra. Estos 180 segundos, corresponden a 6 intercambios de información.

  7. RIP no es capaz de detectar rutas circulares, por lo que necesita limitar el tamaño de la red a 15 saltos. Cuando la métrica de un destino alcanza el valor de 16, se considera como infinito y el destino es eliminado de la tabla (inalcanzable).

Pasada esta pequeña introducción pasemos al ejemplo completo. La estructura del ejemplo es la de siempre:


La configuración de los diferentes dispositivos sería la siguiente:

Configuración de los switch A:

>enable
#configure
Enter configuration commands, one per line. End with CNTL/Z
(config)#ip addres 192.168.1.253 255.255.255.0
(config)#enable secret cisco
(config)#exit
#

Configuración de los switch B:

>enable
#configure
Enter configuration commands, one per line. End with CNTL/Z
(config)#ip addres 192.168.2.253 255.255.255.0
(config)#enable secret cisco
(config)#exit
#

Configuración del Router A:

// Entramos en el modo configuración:
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z

//Pasamos a configurar el interfaz fastethernet.
Router(config)#interface f0/1
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown
14:39:15 %LINK-3-UPDOWN: Interface Fastethernet0/1, changed state to up
14:39:15 %LINEPROTO-5-UPDOWN: Line protocol on Interface Fastethernet0/1, changed state to up

Router(config-if)#exit
//Pasamos a configurar el interfaz Serial. Cambia un poco la configuración entrando en juego varios parámetros nuevos. Por un lado “clock rate” y por otro Bandwidth”. Hay que resaltar que estos parámetros solo se deben configurar en el router que haga de DCE.
Router(config)#interface s0/0
Router(config-if)#no shutdown
14:39:33 %LINK-3-UPDOWN: Interface Serial0/0, changed state to up

<14:39:33 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router(config-if)#ip address 10.0.0.1 255.255.255.0
Router(config-if)#clock rate 9600
Router(config-if)#bandwidth 56000
Router(config-if)#exit

//Guardamos la configuración.
Router#copy running-config startup-config
Building configuration…
[OK]
Router#

La configuración del router B es igual que la del A pero cambiando las IPs correspondientes. Con esto tendríamos configurados todos los equipos pero nos quedaría configurar las rutas dinámicas para ello deberemos usar los siguiente comandos:

# configure terminal
(config)# router rip //Entramos en el modo configuración de protocolo dinámico.
(config-router)#? (algunos de los comandos)

Router configuration commands:

auto-summary Para restaurar la conducta por default de sumarización automática de rutas de subredes en rutas a nivel de red, usamos el comandos de configuración de enrutamiento auto-summary. Para deshabilitar esta función debemos utilizar el prefijo no a este comando.

default-information Control distribution of default information

default-metric Cambia la métrica de las rutas.

distance Define la distancia administrativa.

distribute-list Filter networks in routing updates

exit Sale del modo de configuración.

neighbor Especifica los routers vecinos.

network Defina las redes directamente conectadas.

output-delay Interpacket delay for RIP updates

passive-interface Impedir actualizaciones.

timers Ajustar el tiempo de actualización.

version Selecciona la versión de protocolo.

Para poder concluir nuestro ejemplo deberemos añadir las siguientes líneas a la configuración:

Router A:

(config)#router rip
(config-router)# version 2
(config-router)#
network 192.168.1.0
(config-router)# network 10.0.0.0

Router B:

(config)#router rip
(config-router)# version 2
(config-router)#
network 192.168.2.0
(config-router)# network 10.0.0.0

Para comprobar que todo va bien, podemos usar “show ip route” y por supuesto el comando ping. Por lo tanto para configurar este protocolo de enrutamiento bastará con anunciar las redes a las que estamos directamente conectados.

Ahora sería interesante que probaseis a hacer el ejemplo con tres routers si tenéis alguna duda preguntar.

 

About these ads

18 comentarios

  1. esta guena la pagina loco pero tirame algunos comandos de router con especificacion viteh

  2. LAS COONFIGURACIONES DE LOS SWITCH Y ROURTER ESTAN CONFIGURADAS DE MANERA CORRECTA….ESTA MUY BIEN EXPLICADO INCLUSO PARA PRINCIPIANTES

  3. muy buena explicacion

  4. la configuracion esta buena buena pero un poco de mas comandos y como hacer q toda la red funcione

  5. como configuro 3 redes 3 switches y un router como los interconecto? ayuda gabrielj_f@hotmail.com gracias

  6. Muchas gracias amigo, me ha servido bastante, si la hubiera encontrado antes me hubieras evitado muchas horas de lectura. Facil y Comprensible.

  7. hola veran soy estudiante y me interesa aprender sobre redes y leyendo algunos temas en esta pag q es muy interesante por cierto me encontre con algunas dudas, q espero me puedan ayudar…
    el bandwidth como se q es 56000, lo detemina el equipo o los equipos q tenga conectados no me queda claro…
    de antemano gracias

  8. El término badnwidth se usa para definir la cantidad de datos que puede ser enviada en un periodo de tiempo determinado a través de un circuito de comunicación de datos. 56000 es un valor estandar que le doy yo a la hora de configurar. Si pruebas en algún router o simulador (config-if)# bandwith ? te saldrá la lista de posibilidades que soporta dicho interfaz. Acuerdate que los dos extremos deben comunicarse a la misma velocidad para que se entiendan correctamente. Por eso uno hace de dce y el otro de dte.

  9. hola me pueden ayudar a configurar una red con ambas versiones del rip, es decir una red con 4 router con version 1 y otra igual con version 2 y que ambas redes se comuniquen entre si

  10. hola,
    trabajo con el PT5.0,
    alguien me puede decir por que cuando publico una red con RIPv2(network..) 10.10.10.0 me la lleva a 10.0.0.0???

    Gracias, saludos:D

    • FEDE, lo que pasa es que RIP es un protocolo de enrutamiento “CLASSLESS”. El toma la clase de la red que quieres publicar y publica esa clase completa. Así, si tienes varias subredes todas se publican a la vez.

  11. Hola por favor me podrian ayudar … estoy configurando una red con tres routers y sub redes con RIP Versión 1…. la red esta bien hecha pero me funciona solo por ratos no se que tengo que hacer.

    Por cierto se que mejor es utilizar RIP Versión 2 pero nececito allar el problema de la red anterior con Versión 1 para solucionarlo…… gracias.

  12. es necesario que cOnfigUre el switch? para q funcione la red?
    e estado configurando el router sin configurar el switch!! y en la ruta estatica pues me funciona,,, es diferente con las dinamicas? .. tambien cuando utilizas el comando network y tinenes varios routers conectados tengo q poner network i la red q enlaza a cada router?
    ejm: network 192.168.0.0 (la dl los host conectados a ese router!!compus asi!!)
    network 192.168.6.0(otra red conctada a otro router en tu ejemplo es la 10.0.0.0)
    network 192.168.5.0
    osea:
    network 192.168.0.0
    network 192.168.6.0
    network 192.168.5.0
    y solo lo dejo asi o debo copiarlo con copy running…??
    tengo q usar otro comando para que funcione la red o solo con eso funciona??x q ya lo intente pero al momento d poner el network algo esta mal!!
    Espero y pueda responderm pronto y poes muchsimas gracias!!! x la info expuesta =)!!

  13. gracias muy bueno xD

  14. GRACIASSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS!!!!

    solo me faltaba configurar los saltos de red y que genial ayuda fue eso de router rip, version 2…….

    me funciono a la primera, otravez GRACIAS!!!!!!!!!!!!!!!!!!!!!!!

  15. Gracias por la ayuda en una nomas ejejjeje

  16. amigo una pregunta:
    solo se ponen las redes seriales o tambien se ponen las fastsethernet
    por favor respondeme nesesito saber

  17. hola buenas tardes, quisiera consultarle un inconveniete que tengo para terminar con la configuracion de una red:
    tengo un switch capa 3 powerconnect esta conectado al router que es el que me proporciona el servicio de internet, le tengo creada una vlan de prueba tiene direccion ip (192.168.10.1) el switch tiene activado el enrutamiento(por ser capa3)
    el funcione normal pero entoncs lo que busco es que ademas de funcionar la vlan tambn tenga navegacion a internet!…..
    le doy ping a la direccion del router y me sale host de destino inacessible y al hacer tracert llega hasta la puerta de enlace de la vlan y hay se desborda!….. que puedo hacer, que me puede hacer falta en la configuracion?, alguna ruta estatica qe tenga que configurar??? por favor espero me ayuden porqe se me agotan los recursos para solucionar este inconveniente!

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

%d personas les gusta esto: