Configuración básica de un switch 1900 Cisco.

Vamos a tratar de aprender a configurar un Switch 1900 de Cisco, para ello deberemos aprender varios comandos.

Al conectarnos al Switch vía puerto serial o vía telnet nos aparecerá la siguiente pantalla, en la que podremos elegir configurarlo por menús o desde línea de comandos. Nosotros elegiremos la segunda.

Catalyst 1900 Management Console
Copyright (c) Cisco Systems, Inc. 1993-1999
All rights reserved.
Enterprise Edition Software
Ethernet Address: 00-30-80-C7-BE-C0

PCA Number: 73-3122-04
PCA Serial Number: FAB033723WJ
Model Number: WS-C1912-A
System Serial Number: FAB0338S10A
Power Supply S/N: APQ032404SA
PCB Serial Number: FAB033723WJ,73-3122-04
————————————————-

1 user(s) now active on Management Console.

User Interface Menu

[M] Menus
[K] Command Line

Enter Selection:

Pulsamos K y apareceremos en la línea de comandos.

More...Modos de la línea de comandos.

Existen tres modos: invitado(>), usuario privilegiado(#) y modo configuración((config)#). Representan los niveles de privilegios para llevar a cabo la configuración del Switch. En el modo que aparecemos por defecto es obviamente el de invitado. Los comando para pasar de un modo a otro son los siguientes:

Menú Inicial Pulsamos k para pasar a modo invitado
> Modo invitado
> Exit Volvemos al Menú
Menú k  
> enable Pasamos de modo invitado a modo privilegiado
# Modo privilegiado
# disable Volvemos al modo invitado
# configure Pasamos al modo configuración.

dibujo1.jpg

Dependiendo en que modo estemos podremos usar unos comandos u otros. Para ver que comandos podemos utilizar dentro del modo en el que nos encontramos bastara con utilizar “?” en la línea de comandos.Por ejemplo estos serán los comandos que podremos usar desde el modo invitado.

>?

Exec commands:

enable Turn on privileged commands
exit Exit from the EXEC
help Description of the interactive help system
ping Send echo messages
session Tunnel to module
show Show running system information
terminal Set terminal line parameters
   

De entre estos comandos se encuentra uno muy importante, “show”. Con este comando podremos mostrar desde la versión del sistema hasta la configuración. Podemos probar con los siguientes modificadores:

  • >show ip (Muestra la configuración IP).
  • >show version (Muestra la versión del sistema).
  • >show history (Muestra la lista de comandos utilizados).

Para saber los modificadores de cada uno de los comandos bastará con utilizar otra vez “?” de la siguiente forma:

#show ?

Nos aparecerá una lista de los posibles modificadores.

Ya tenemos una idea general asi que vamos a pasar a lo importante y empecemos a configurar el Switch, para hacerlo vamos a seguir los siguientes pasos:

  1. Le daremos un nombre.
  2. Le daremos una IP.
  3. Le daremos una contraseña al mode enable para que automáticamente se active el servicio de terminal.

Para realizar esta configuración nos bastará con seguir los siguientes pasos:

>enable
#configure
(config)# hostname Bilbao
bilbao(config)# ip address 192.168.1.1 255.255.255.0
bilbao(config)#enable secret cisco
bilbao(config)#exit
bilbao#show ip
Explicación:
Entramos en el modo usuario privilegiado.
Pasamos al modo configuración.
Le damos el nombre Bilbao al Switch.
Configuramos la IP.
Ponemos “cisco” como contraseña de entrada al modo enable.
Volvemos al modo privilegiado.
Mostramos la configuración.
 

Con esto ya habremos hecho la configuración básica del switch. Otro día pasamos a otras configuraciones.

About these ads

29 comentarios

  1. QUISIERA QUE HAYAN MAS CONFIGURACIONES COMO DE OTROS SWITCH Y ROUTERS

  2. SOY DE BOGOTA ME AYUDAN CON ESTAS CONFIGURACIONES SOLICITADAS

  3. fcgsdr5

  4. cuentame que tipo de configuraciones te gustaría que pusiese y hare lo posible por ponerlas. En estos momentos estoy preparando configuraciones de protocolos de enrutamiento dinámico,(RIP,OSPF,IGRP,…).
    Mi idea es ir colocando poco a poco diferentes tipos de configuraciones, para que todos podamos ir aprendiendo, pero lo dicho si quieres alguna configuración en especial me la mandas y trato de hacerla. Un saludo y gracias visitar el blog.

    • Hola me parece muy intersante tu informacion, pero quisiera que me dijheras como puedo configurar un switch cisco 2960 en modo grafico, lo que pasa es que reseteo el switch y conecto el cable punto a punto del switch al PC y luego escribo la direccion IP del switch en el navegador y me aparece que no se puede mostrar la pagina solicitada.

      Entonces quisiera que por favor me dijera como como puedo coonfigyurar un switch cisco 2960 en una red LAN, en modo grafico, wntoncs quisiera que por favor me diera link de donde puedo buscar informacion, si me puedes ayudar mi correo es:

      vicmanuel@misena.edu.co

      Gracias y espero tu ayuda….

  5. Hola, como puedo obtener la clave de configuracion del switch, o si puedo cargar las configuraciones por defecto para generar una nueva password como en un router

  6. Buenos días, he encontrado esta URL que puede servir de ayuda:

    http://www.cisco.com/en/US/products/hw/switches/ps628/products_password_recovery09186a0080094184.shtml

    Un resumen de los pasos sería el siguiente:

    – Debes conectarte por consola.
    – Apagas el switch y con el botón MODE apretado durante unos segundos lo enciendes.
    – Cuando arranque deberías tener acceso por consola.
    – Haces un dir y show flash y veras que te aparece un config.txt.
    – Si quieres guardar la configuración actual debes hacer un more del archivo config.txt y copiarlo en el bloc de notas por ejemplo.
    – Luego renombra ese archivo mediante rename flash:config.txt flash:configold.txt y reinicia el aparato, en teoría podrás volver a configurarlo.

    Si esto no funciona prueba a hacer control+breack cuando reinicie el equipo a través de la consola.

    Un saludo y espero haberte ayudado un poco.

  7. hola dis cululpen de ante mano soy nuevo en esto de las configuraciones y quisiera saver si podrias poner los comandos para la configuracion del router plis se los agradeceria

  8. Puedes mirar configuración de red 1 y 2. De todas formas para la próxima semana colgaré un resumen de los comandos principales para configurar el router.

    Un saludo y gracias por visitar el blog.

  9. hola amigos soy nuevo en esta pagina saben necesito una ayuda la verdad no se mucho sobre configuraciones de routers… de hecho nada y tengo un prooooblema, tengo un block de notas con unas configuraciones para una conexion al backbone de internet 2 y bueno kiero una breve explicacion de lo que se hace en cada linea si esto no es posible…pues solo la de los comandos mas importantes es indispensable por que es parte de mi proyecto de titulacion, aunque no es mi tema principal lo necesit muchas gracias por su ayuda por que nos hechan la mano como no tienen idea!!! gracias!!!
    Current configuration : 1598 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname RISEPSE-VER1A-0000166P
    !
    boot-start-marker
    boot-end-marker
    !
    card type e1 1
    enable password XXXXXXXXX
    !
    no aaa new-model
    !
    !
    ip cef
    !
    !
    ip name-server 200.33.146.217
    ip name-server 200.34.149.200
    !
    voice-card 0
    no dspfarm
    !
    !
    controller E1 1/0
    framing NO-CRC4
    channel-group 0 timeslots 1-31
    !
    !
    interface Tunnel1
    ip address 201.117.74.53 255.255.255.252
    tunnel source 201.117.75.41
    tunnel destination 200.38.193.254
    !
    interface FastEthernet0/0
    description LAN LOCAL CUDI IT ORIZABA
    ip address 201.116.120.49 255.255.255.240
    duplex auto
    speed auto
    no keepalive
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial1/0:0
    description Enlace INTERNET-2 de 2048K_REF D32-0705-0603
    bandwidth 2048
    ip address 201.117.75.41 255.255.255.252
    encapsulation ppp
    no fair-queue
    !
    router bgp 65104
    no synchronization
    bgp log-neighbor-changes
    network 201.116.120.48 mask 255.255.255.240
    neighbor 201.117.74.54 remote-as 65002
    no auto-summary
    !
    ip route 0.0.0.0 0.0.0.0 201.117.75.42
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    exec-timeout 30 0
    password XXXXXXXXXXXX
    login
    line aux 0
    exec-timeout 30 0
    password XXXXXXXXXXXXX
    login
    modem InOut
    transport input all
    stopbits 1
    flowcontrol hardware
    line vty 0 4
    exec-timeout 30 0
    password XXXXXXXXXXXX
    login
    !
    scheduler allocate 20000 1000
    !
    end

  10. Ok Hiram. Dejame un par de dias q ahora estoy un poco liado. Pero intentaré contestarte esta semana. De todas formas si esta es una configuración real, procura no incluir las IP o cambiarlas por seguridad. Un saludo y gracias por visitar el blog.

  11. Hola, sabes como configurar VLAN ‘S. seria vacano si muestras los comandos de configuración

  12. hola necesito saver como puedo configurar un switch 2500 cisco

  13. Hola me gustaria que me pudieras explicar como puedo pasar un archivo que esta en formato configuration settings a formato Lang. Gracias

  14. Hola, a ver si me pueden ayudar quiero saber en este modelo de switch como puedo saber que puertos estan disponibles

  15. Me podian explicar como puedo configurar un switch 1900 cisco, como se puede configurar las Vlan, como hacerlos independientes…, Gracias de antemano espero sus respuestas…

  16. Desearia conocer modelos de configuracion para equipos catalyst 2960 y 3705

  17. No me gusta nada de lo que esta aqui todos son unos brutos!!

  18. DEBISTE DE LEER EL TITULO PRIMERO QUERIDA JUANA.

  19. Disculpen estoy haciendo un examen de cisco y quisiera saber si a un switch cisco 1900 series se le puede cambiar el vtp version ya lo he intentado con #vlan database #vtp v2-mode por su ayuda gracias

  20. Necesito configuración para un switch MRV MR2226-2C-POE o alguno parecido.

  21. no entendi nada de lo que intentaste dar a conocer nimodo

  22. Hola, quiero saber como entrar a la configuraciòn del swicth, tengo un Catalyst 2960, pero no se como hago para entrar al promp para entrar al modo consola, Tengo que instalar algun programa propietario?? gracias

  23. quiero sabes como es el comando de mensaje de vienbenida

  24. es urgente

  25. a
    a
    a

  26. HOLA QUISIERA, SABER COMO PUEDO ACTUALIZAR LA IOS DE UN SWITCH CATALYSTS 1900 Y DONDE PUEDO ENCONTRAR UNA ACTUALIZACION DE LA MISMA Q NO SEA DESDE LA PAGINA PRINCIPAL DE CISCO…..

  27. hola tengo un cisco catalyst 1900 series de 12 puertos que en la parte tracera aparece como modelo (ws-c1912-a) me gustaria saber si es posible cambiar mi ios por que en la que tengo actualmente no puedo acceder ala linea de comandos. me gustaria pedirles que porfavor me facilitaran esta ios para asi poder practicar.
    gracias

  28. Buenos dias a toditos me gusta todo lo relacionado con harware y software de redes y maquinas, estoy aprendiendo de todos ustedes les doy millones de gracias y pienso que cuando obtenga mas conocimientos compartirlos por que nadie nace aprendidio

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

A %d blogueros les gusta esto: